Technorati Rank WordPress Plugin Version 2 Çıxdı!

İlk Technorati Rank Pluginin topuqlarında isti, çıxış məzmunu etmək üçün yenidən hazırladım CSS idarə olunur (aşağıda ekran görüntüsü, saytımın kenar çubuğundakı ilə əlaqə qura bilərsiniz):

Technorati Rank WordPress Plugin Version 2

Bunu istehsal etmək biraz daha çətin idi, lakin nəticəsi daha gözəldir. Əvvəlcə öyrəndiyim şeylərdən istifadə etdim Bittbox şəkildəki çıxış düymələrinin hər birini Illustrator-da etmək.

Növbəti addım əslində birinin qurulması üçün üslublardan istifadə edildi şəkil xəritəsi xaricində əslində var xəritə yoxdur! Əslində olduqca sərin. Ümumi div fonunu təyin edə və sonra mütləq yerləşdirmə və CSS-dən istifadə edərək 'isti nöqtələrin' hər birini yarada bilərsiniz. Çıxış CSS-yə baxın.

Technorati-nin yenisinə bir link də əlavə etdim WTF səhifə və saytın RSS ünvanı. Ümid edirəm bəyənəcəksiniz! İlk versiyadan böyük bir inkişaf olduğunu düşünürəm! Bir var i plagini də təşviq edən sağ altdakı link.

Mövcud Technorati Rank WordPress Plugin Version 2.0.4

23 Şərhlər

  1. 1
    • 2

      Əlbətdədir! Bir müddətdir Illustrator yardımını axtarırdım. Bunu fantastik etmək üçün kifayət qədər istifadə etmirəm, buna görə Bittbox kimi bir sayt mənə çox vaxt qazandırır!

  2. 3

    İstiqamətlərinizi ən yeni və ən böyüyünü “hərf” ə qurmağa çalışdım 🙂

    ancaq aşağıdakı səhvi aldım

    Ölümcül səhv: mövcud olmayan sinfi təsəvvür etmək olmur: 4-cü sətirdə /home/winex64/public_html/wp-content/plugins/technorati-rank/technorati-rank.php simplexmlelement

    hər hansı bir təklif?

    • 4
      • 5

        əvvəlcə yoxlamağı öyrədəcək .. görünür Lunarpages 4.4.4 PHP işləyir

        Digər versiyasını yoxlamaq və ya sərt bir şəkildə asmaq və 5.0-a yüksəldiklərini yoxlamaq məcburiyyətindəyəm

        • 6

          İnşallah edərlər! Ancaq ümid edirəm ki, ev sahibi yeniləyir. PHP5 həqiqətən daha yaxşı performans inkişafları və API istifadə etmək üçün daha yaxşı alətlər gətirir. Jumpline istifadə edirəm, ana səhifəmdə sponsor siyahımda bir keçid görəcəksiniz. Dotster-in ən son və ən yaxşısına sahib bəzi yaxşı VDS-lərə sahib olduğuna da inanıram.

      • 7

        Doug,
        Eyni problemi yaşayıram
        Ev sahibinə zəng etdim və serverimdə PHP 4 və PHP 5 olduğunu dedilər, ancaq PHP 5 istifadə edərək bir sənəd çalıştırmaq istəsən, skriptin .php5 fayl uzantısına sahib olması lazım olduğunu söylədilər.

        Beləliklə ... Fayl uzantılarını dəyişdirdim və wordpress-dəki plaginlərdən yox olur.

        Fikirləriniz varmı?

  3. 10

    Awesome Plugin, Əla üslub! Təşəkkür edirəm Doug və əla iş. Birincisini heç bilmirdim, amma bu, yan panelimin prontosunda gedir.

    Illustrator tövsiyələrimin düymələrinizi düzəltməyinizə kömək etdiyini görmək Həqiqətən mükafatlandırılır !!!!!

    yenidən Təşəkkürlər,

    ~ BittBox

    • 11

      Təşəkkür edirəm, BittBox! Stil üçün yaxşı bir gözə sahib olduğumu düşünürəm, amma əksər hallarda bunu heç vaxt düzgün görmürəm. Həqiqətən nümunələrinizi yükləyə və parçalaya bilmək fərqi yaradır. İndi o fikirləri həqiqətən icra edə bilirəm. 🙂

      Blogumun başlığı və arxa planındakı bəzi düşüncələrlə oynayıram.

  4. 12

    Doug, deyəsən 2-ci versiya plagini mənə nifrət edir. Səhv mesajları alıram:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Hata mesajlarına baxmayaraq, Technorati dərəcəmi də göstərir (~ 26.5k: D). PHP-nin niyə bu bir fayl üzərində ağladığını bilmək üçün kifayət qədər məlumatlı deyiləm.
    Maraqlısı odur ki, serverimizdə SuPHP-dən istifadə edirik, buna görə hər şey bizim kimi işləyir (beləliklə, chmod tələbləri artıq dünya tərəfindən yazıla bilən sənədlər tələb etmir və məsələn, chmod'un həddindən artıq yüksək olması halında php skriptləri icra olunmayacaq).

    Bu alt alan üçün bütün phplər php5 olaraq işləyir.

    Hər hansı bir fikir?

    • 13

      Xial wp-content / cache qovluğunuz varmı? WP-Cache ilə eyni cache qovluğundan istifadə etməyin yaxşı bir fikir olacağını düşündüm. Geriyə baxanda bəlkə də yaxşı bir fikir deyildi! Bu sətir mütləq önbellek sənədinə yazmaq üçündür.

      • 14

        Əlbətdə edirəm, Doug. Bir müddətdir ki, WP-Cache işlədirəm. 🙂

        Lazımi qovluğum var, amma bunun tamamilə başqa bir şey olduğunu təxmin etdiyim üçün bu barədə niyə şikayət etməyim barədə bir az maraqlandım.

      • 15

        Əlavə etmək üçün maraqlı bir az məlumat:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Hələ də səhvləri qaytarır.

    • 16

      Eyni səhvə sahib olmaq üçün səsləndirmək istəyirəm. Sayt php5 işləyir və düyməni göstərir.
      121-123 sətirlərini şərh etməyə çalışdım və fiş yaxşı işləyir. Canlı qoya bilərəmmi, yoxsa bu xətlərin olmaması daha uzun müddətdə problemə səbəb olacaq?

  5. 17

    Yuxarıda göstərilən səhvləri alıram, bunun da mənim önbellek olduğumu düşünürdüm, ancaq bir də var və yazma hüquqlarının düzgün olduğundan əmin oldum.
    Yan çubuqda plagini (dərəcə ilə) göstərəcək, ancaq yuxarıdakı səhvlərlə.

    • 18

      Salam Richard,

      PHP versiya 5+ və CURL-un aktiv olduğunu yoxlaya bilərsinizmi? Bunu saytınızda bir səhifə quraraq edə bilərsiniz <?php phpinfo(); ?> bir səhifədə. Sonra həmin səhifəni açın. Səhifənin yuxarı hissəsində PHP versiyanız olacaq və effektivliyini təmin etmək üçün CURL üçün bir axtarış edə bilərsiniz.

      Thanks!
      Doug

      • 19

        Doug, PHP versiyamı iki dəfə yoxladım.
        PHP5 işləyirəm və cURL tərtib olunur (PHP-yə tərtib edilməsi üçün ev sahibinə etdiyim adi üç istəkdən biri).

        Hər şey yaxşı işləyir, amma PHP-də tərtib edilmiş cURL versiyası olmadığı müddətdə bu plaginin niyə boğulduğundan tam əmin deyiləm (7.15.4-dəyik və ən son 7.16.1 kimi görünür). Bununla birlikdə, ev sahibimə php5-i yenidən bunun üçün kompilyasiya etmək istəmirəm, əgər kömək edə bilsəm. <: 3

        • 20

          Bu həftə sonu daha dərindən baxacağam. Bir neçə saytda heç bir problem olmadan işləyir - buna görə 3 şeydən biridir: 1. Cache, 2. cURL və ya 3. PHP Versiyası.

          XML-i çəkmək və təhlil etmək üçün köhnə PHP 4 funksiyasından istifadə edə bilərəm, ancaq onu bir az ləngidə bilər - bu həftə sonu test edəcəyəm. Bütün girişləri qiymətləndirirəm. "Houston, problemimiz var!".

  6. 21

    Yalnız bir qeyd: Technorati bir Səlahiyyət Plugin.

    Ayrıca - bu plaginlə problem yaşayanların hamısı üçün həqiqətən yeni bir ev sahibliyinə keçməyinizi məsləhət görürəm :). Evimin altındakı ev sahibimlə birlikdə 12 aylıq pulsuz bir xüsusi var haqqında səhifə.

  7. 22
  8. 23

    Önbellek faylından yazarkən və ya oxuduqda səhvlər olduğuna dair bir neçə istək aldım. Önbellek faylını kök qovluğuna itələdiyim və çəkdiyim bir problemi həqiqətən təyin etdim. 2.0.4 versiyasını dəyişdirdim ki, plaginin qovluğundakı bir önbelleğe yazsın.

    Xahiş edirəm mənə necə işlədiyini bildirin! (Hələ SimpleXML və cURL lazımdır!)

Siz nə düşünürsünüz?

Bu sayt spam azaldılması üçün Akismet istifadə edir. Yorumunuzun necə işləndiyini öyrənin.